您的位置:首页 > 其它

HDU 3038 How Many Answers Are Wrong

2015-07-28 17:06 162 查看
[align=left]Problem Description:[/align]
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).



Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

[align=left]Input[/align]
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

[align=left]Output[/align]
A single line with a integer denotes how many answers are wrong.

[align=left]Sample Input[/align]

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

[align=left]Sample Output[/align]

1

题意: Ai~Bi 的和是 Si,现在共有 N 个数,给你 M 条信息,判断错误的信息有多少。 那么 Ai~Bi 的和 Si 可以看做 1~Bi 的和比 1~Ai-1 的和大 Si
+———————+———————————————+
A C B
知道A~B的和为100, A~C的和为40, 而C~B的和却为50, 可见有一个错误说法

#include<stdio.h>
#define N 200010
int f
, r
, n;
void Init()
{
int i;
for (i = 0; i <= n; i++)
{
f[i] = i;
r[i] = 0;
}
}
int Find(int x)
{
int k = f[x];
if (f[x] != x)
{
f[x] = Find(f[x]);
r[x] = r[k]+r[x];
}
return f[x];
}
int main ()
{
int m, a, b, c, na, nb, ans;
while (scanf("%d %d", &n, &m) != EOF)
{
Init();
ans = 0;
while (m--)
{
scanf("%d %d %d", &a, &b, &c);
a--; //就像6~10的和是1~10的和比1~5的和多的部分,需要将a减1
na = Find(a);
nb = Find(b);
if (na == nb && c+r[a] != r[b])
ans++;
else if (na < nb)
{
f[nb] = na;
r[nb] = (c+r[a])-r[b];
}
else if (na > nb)
{
f[na] = nb;
r[na] = r[b]-(r[a]+c);
}
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: