您的位置:首页 > 其它

PAT (Advanced Level) 1067. Sort with Swap(0,*) (25) 只能与0交换

2015-07-28 16:07 441 查看
Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following
way:

Swap(0, 1) => {4, 1, 2, 0, 3}

Swap(0, 3) => {4, 1, 2, 3, 0}

Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10 3 5 7 2 6 4 9 0 8 1

Sample Output:
9

/*2015.7.28cyq*/
#include <iostream>
#include <vector>
using namespace std;

//有两种环,一种含关键数0,一种不含(需要多出破环和补环两次操作)
int main(){
int N;
cin>>N;
vector<int> a(N);
for(int i=0;i<N;i++)
cin>>a[i];
vector<bool> used(N,false);
//0与count个数连成一个环,可通过count次交换后0回到a[0],其它数位置均正确
int next=0;
int count=0;
while(a[next]!=0){
next=a[next];
used[next]=true;
count++;
}
//非0的K个数连成一个环,共K+1次操作:a[0]处的0与环中任意一个数交换,环K-1次交换,补环(0回到a[0])
for(int i=1;i<N;i++){//可能有很多个环
if(!used[i]&&a[i]!=i){//没用过且放错位置的数,说明是一个新环
used[i]=true;
int K=1;
int t=i;
while(a[t]!=i){
t=a[t];
used[t]=true;
K++;
}
count=count+K+1;
}
}
cout<<count;
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: