您的位置:首页 > 其它

HDU 1347 Grandpa is Famous

2015-07-28 14:09 459 查看


Grandpa is Famous

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 704 Accepted Submission(s): 244



[align=left]Problem Description[/align]
The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player
ever, whow, that was astonishing!

The International Bridge Association (IBA) has maintained, for several years, a weekly rank? ing of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player
ever because he got the highest number of points.

Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list
of weekly rankings, finds out which player(s) got the second place according to the number of points.

[align=left]Input[/align]
The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the
number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly
ranking. You can assume that:

1. in each test case there is exactly one best player and at least one second best player,

2. each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

[align=left]Output[/align]
For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print
the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

[align=left]Sample Input[/align]

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0


[align=left]Sample Output[/align]

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100


[align=left]/*本来想应该会超时,结果只花了177MS*/[/align]
[align=left]/*思路:题目是要你把投票票数第二的那些号码按递增序列输出,输入序号时就可以开始统计票数,题目数据量不大,把序号作为一个数组下标,若读入相同的序号,则对应下标数组加一,读完也就统计完所有的票数,再用一个结构体,有两个变量,一个存序号,一个存下标,然后先根据票数排序,选出票数排名第二的,然后再根据序号递增排序*/[/align]

[align=left]代码如下[/align]

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 10000+10
using namespace std;
int a[maxn][maxn],b[maxn],c[maxn];
struct node
{
int cnt; //存储票数
int id;  //存人的序号
};
int rule(node x,node y)
{
return x.cnt>y.cnt;
}
int  main()
{
int n,m,i,j;
node stu[maxn];
while(~scanf("%d %d",&n,&m),n+m)
{
memset(b,0,sizeof(b));
for(i=0;i<n;i++)
for(j=0;j<m;j++) scanf("%d",&a[i][j]),b[a[i][j]]++;
j=0;
for(int i=0;i<maxn;i++) if(b[i]) stu[j].cnt=b[i],stu[j].id=i,j++;
sort(stu,stu+j,rule);
//for(int i=0;i<j;i++) printf("%d ",stu[i].cnt);
int max=0,min;
while(stu[max].cnt==stu[0].cnt) max++;
min=max;
while(stu[min].cnt==stu[max].cnt) min++;
j=0;
for(int i=max;i<min;i++) c[j]=stu[i].id,j++;
sort(c,c+j);
for(int i=0;i<j-1;i++) printf("%d ",c[i]);
printf("%d\n",c[j-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: