您的位置:首页 > 其它

HUD 1002 A + B Problem II

2015-07-28 12:33 162 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 261740 Accepted Submission(s): 50656



Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211


Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


思路 大数加法高精度

#include<stdio.h>

int main()
{
int n,i,d,n1,n2,p;
char a[1100], b[1100],c[1100],x;
scanf("%d",&n);
getchar();
for(i=1;i<=n;i++)
{
d=0;p=0;
while((x=getchar())!=' ')
{
a[d]=x;
d++;
}
n1=d-1;
d=0;
while((x=getchar())!='\n')
{
b[d]=x;
d++;
}
n2=d-1;
printf("Case %d:\n",i);
for(d=0;d<=n1;d++)
{
printf("%c",a[d]);
}
printf(" + ");
for(d=0;d<=n2;d++)
{
printf("%c",b[d]);
}
printf(" = ");
for(d=0;n1>=0||n2>=0;n1--,n2--,d++)
{
if(n1>=0&&n2>=0)
{
c[d]=a[n1]+b[n2]-'0'+p;
}
if(n1>=0&&n2<0)
{
c[d]=a[n1]+p;
}
if(n2>=0&&n1<0)
{
c[d]=b[n2]+p;
}
p=0;
if(c[d]>'9')
{
c[d]=c[d]-10;
p=1;
}
}

if(p==1)
{
printf("1");
}
while(d--)
{
printf("%c",c[d]);
}
if(i==n)
{
printf("\n");
}
else
printf("\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: