您的位置:首页 > 其它

hdoj 2147 kiki's game

2015-07-27 21:27 441 查看

kiki's game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 40000/10000 K (Java/Others)

Total Submission(s): 8040 Accepted Submission(s): 4779



[align=left]Problem Description[/align]
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one
people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

[align=left]Input[/align]
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

[align=left]Output[/align]
If kiki wins the game printf "Wonderful!", else "What a pity!".

[align=left]Sample Input[/align]

5 3
5 4
6 6
0 0


[align=left]Sample Output[/align]

What a pity!
Wonderful!
Wonderful!


思路:这是一道博弈题,找出规律就简单了,设N为必胜点,P为必败点。

可得图



只要m或n有一个是偶数就可获胜。

代码:

#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d%d",&n,&m),(n+m)!=0)
{
if(n%2==0||m%2==0)
{
printf("Wonderful!\n");
}
else
{
printf("What a pity!\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: