您的位置:首页 > 其它

UVA 10420(排序检索)

2015-07-27 17:54 337 查看
题目:In Act I, Leporello is telling Donna Elvira about his master’s long list of conquests:

“This is the list of the beauties my master has loved, a list I’ve made out myself: take

a look, read it with me. In Italy six hundred and forty, in Germany two hundred and

thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and

three! Among them are country girls, waiting-maids, city beauties; there are countesses,

baronesses, marchionesses, princesses: women of every rank, of every size, of every age.”

(Madamina, il catalogo questo)

As Leporello records all the “beauties” Don Giovanni “loved” in chronological order, it is very

troublesome for him to present his master’s conquest to others because he needs to count the number

of “beauties” by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines. The first line contains a number n, indicating that there will

be n more lines. Each following line, with at most 75 characters, contains a country (the first word)

and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the

name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed

by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3

Spain Donna Elvira

England Jane Doe

Spain Donna Anna

Sample Output

England 1

Spain 2

题目大意:

统计输入同一国家的人的数量,并对国家进行按字母从小到大的排序

方法:

将国家与名字输入同一串中,然后再截取国家到一个字符串数组中,用qsort对国家进行排序,然后统计每个国家重复的量,并输出。

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
using namespace std;

int comp(const void *a, const void *b) {
return strcmp((char*)a, (char*)b);
}

char data[2000][75];
char country[2000][75];

int main() {
int num, number=1;
int i, j, k=0;

scanf("%d", &num);
getchar();
for(i=0; num>0; i++,num--) {

gets(data[i]);

}
for(j=0; j < i; j++) {
k=0;
while(data[j][k]!=' ') {
country[j][k]=data[j][k];
k++;
}
}

qsort(country,i,75,comp);
for(j=0; j < i; j++) {
k=j;
number=1;
while(strcmp(country[k],country[k+1])==0) {
k++;
j++;
number++;
}
printf("%s %d\n", country[j], number);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: