您的位置:首页 > 其它

zoj2987 Misspelling

2015-07-27 17:04 375 查看
Misspelling

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

Misspelling is an art form that students seem to excel at. Write a program that removes the nth character from an input string.

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the
word is guaranteed to be less than or equal to 80.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.

Sample Input

4

4 MISSPELL

1 PROGRAMMING

7 CONTEST

3 BALLOON

Sample Output

1 MISPELL

2 ROGRAMMING

3 CONTES

4 BALOON

Source
Greater New York Region 2007

分析:
水题。
ac代码:

#include <iostream>

#include<cstdio>

#include<cstring>

using namespace std;

int main()

{

int n,m,i;

char c[85];

int len,t=0;

scanf("%d",&n);

while(n--)

{

scanf("%d",&m);

scanf("%s",c);

printf("%d ",++t);

len=strlen(c);

for(i=0;i<len;i++)

{

if(i==m-1)

{

continue;

}

printf("%c",c[i]);

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: