您的位置:首页 > 其它

A - Accurately Say "CocaCola"! --- (first qualifying)

2015-07-27 16:15 405 查看
A - Accurately Say "CocaCola"!
时限:2000MS 内存:65536KB 64位IO格式:%lld
& %llu

问题描述

In a party held by CocaCola company, several students stand in a circle and play a game.
One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number
which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.
For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should
say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.
During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?
For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation
happen.
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases.
And it will be followed by T consecutive test cases.
There is only one line for each case. The line contains only one integer p (1 <= p <= 99).
Output
Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s
stands for.
Sample Input

2
2
3


Sample Output

27
70


分析:手速题,10分钟AC。意思就是说输入一个n值,在正整数内,连续n个数满足条件:数字中含有7或者这个数是7的倍数。问连续n个数中的最小数是多少?题目中说n值最大为99,所以直接想到暴力解决。

CODE:

<span style="font-size:18px;">#include <iostream>
#include <string.h>
using namespace std;

int main()
{
int t;
cin>>t;
while(t--){
int p;
cin>>p;
int cnt=0,arr[10];
for(int i=1;i<800;i++){
int x=i;
memset(arr,0,sizeof(arr));
while(x){
arr[x%10]=1;
x/=10;
}
if(i%7==0||arr[7]){
cnt++;
}
else
cnt=0;
if(cnt==p){
cout<<i-p+1<<endl;
break;
}
}
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: