您的位置:首页 > 其它

hdoj 1312 Red and Black【DFS】

2015-07-27 15:12 316 查看


Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13197 Accepted Submission(s): 8181



Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[22][22];
int j, k, t;
void digui(int x,int y)
{
if(x<1 || x>k || y<1 || y>j)
return  ;
if(s[x][y] == '#')
return  ;
t++;
s[x][y]='#';
digui(x,y-1);
digui(x,y+1);
digui(x-1,y);
digui(x+1,y);

}
int main()
{
int u,i;
int x,y;
while(scanf("%d%d",&j,&k)!=EOF,j|k)
{
getchar();
t = 0;
for(i=1;i<=k;i++)
{
for(u=1;u<=j;u++)
{
scanf("%c",&s[i][u]);
if(s[i][u]=='@')
x=i,y=u;
}
getchar();
}
digui( x, y);
printf("%d\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: