您的位置:首页 > 其它

HDU - 1213 How Many Tables 解题报告

2015-07-27 10:40 447 查看


How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17994 Accepted Submission(s): 8853



Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


题意:

有t组数据,每组数据开头为m,n。表示有m个人,下面n行表示a,b相互认识,认识可以传递,即a认识b,b认识c,那么a就认识c。认识的人可以用同一张桌子,问一共需要多少张桌子。

题解:

将认识的人归为一组,可以用并查集解决。

参考代码:

#include<stdio.h>
#include<string.h>
#define N 1005
int father
;
int f(int n)
{
return father
==n?n:father
=f(father
);
}
void merge(int x,int y)
{
int fx,fy;
fx=f(x);
fy=f(y);
if(fx!=fy)
father[fx]=fy;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int m,n,a,b,sum;
sum=0;
for(int i=1;i<N;i++)
father[i]=i;
scanf("%d%d",&m,&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
merge(a,b);
}
for(int i=1;i<=m;i++)
{
if(father[i]==i)
sum++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: