您的位置:首页 > 其它

ZOJ - 2781 Rounders

2015-07-27 10:10 183 查看
Rounders

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

Introduction

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand,
and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.

Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446


Sample Output

20
10
4
5
100
10000000
50000000
2000
500


Source
South Central USA Regional Programming Contest 2006

分析:
水题。
ac代码:
#include <iostream>

#include<cstdio>

#include<cmath>

using namespace std;

int main()

{

int n,i,x,x2;

int c;

scanf("%d",&n);

while(n--)

{

scanf("%d",&x);

c=0;

x2=x;

for(;x2;x2/=10)

{

c++;

}

//printf("c=%d\n",c);

for(i=1;i<c;i++)

{

if(x%(int)(pow(10,i))>=(int)5*(pow(10,i-1)))

{

x=x-x%(int)(pow(10,i))+(int)(pow(10,i));

//printf("xx=%d",x);

}

else

{

x=x-x%(int)(pow(10,i));

//printf("xx=%d",x);

}

}

printf("%d\n",x);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: