您的位置:首页 > 其它

HDU1003 简单DP

2015-07-27 09:43 357 查看

Max Sum

[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

[align=left]Sample Output[/align]

Case 1: 14 1 4 Case 2: 7 1 6

#include <bits/stdc++.h>
using namespace std;

int main() {
int T,n;
int Max, S, E, sum, a;
cin >> T;
for(int t = 1; t <= T; ++t) {
cin >> n;
S = E = sum = 0;
Max = -100000;
int k = 0;
for(int i = 0; i != n; ++i) {
cin >> a;
sum += a;
if(sum > Max) {
Max = sum;
S = k;
E = i;
}
if(sum < 0) {
sum = 0;
k = i + 1;
}
}
cout << "Case " << t << ":" << endl;
cout << Max << " " << S+1 << " " << E+1 << endl;
if(t < T) puts("");
}
return 0;
}


不用数组
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: