您的位置:首页 > 其它

HDOJ DNA Sorting(第一周)

2015-07-27 08:38 405 查看

DNA Sorting

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3
[align=left]Problem Description[/align]
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters
to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it
is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

 

[align=left]Input[/align]
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.
 

[align=left]Output[/align]
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
 

[align=left]Sample Input[/align]

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

 

[align=left]Sample Output[/align]

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

这道题难点在于读懂题意,题意读懂了,就好做了,这道题的意思是,计算每个字符串中一个字符后面的比他小的字符的个数总和,例如:AACATGAAGG
比第一位小的为0个,同理,第二个也为0个,第三个c有3个,第五个T有5个,第六个G有2个,总和9个,依次求出,然后排序输出。

ac代码:
<pre name="code" class="cpp">#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct s
{
char cc[1000];
int num;
}str[1000];
bool cmp(s a, s b)  //按照数量排序
{
return a.num<b.num;
}
int main()
{
int n,m,i,k,j;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(i=0;i<m;i++)
{
str[i].num=0;
scanf("%s",str[i].cc);
for(j=0;j<n;j++)
for(k=j+1;k<n;k++)
{
if(str[i].cc[j]>str[i].cc[k])
str[i].num++;
}
}
sort(str,str+m,cmp);
for(i=0;i<m;i++)
printf("%s\n",str[i].cc);
}
return 0;
}




 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: