您的位置:首页 > 其它

hdu 1008(Elevator)

2015-07-26 20:44 447 查看


Elevator(原网址:http://acm.hdu.edu.cn/showproblem.php?pid=1008

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 52147 Accepted Submission(s): 28781



[align=left]Problem Description[/align]
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one
floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

[align=left]Input[/align]
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

[align=left]Output[/align]
Print the total time on a single line for each test case.

[align=left]Sample Input[/align]

1 2
3 2 3 1
0


[align=left]Sample Output[/align]

17
41


题意:
一个电梯往上一层要6秒,往下一层要4秒,每层停留5秒,电梯开始在0层,给你电梯总共运行次数n,后面的n个数为这n次分别到的层数,求运行时间。(多组数据,当n为0时结束)

参考代码:
#include<iostream>
using namespace std;
int main()
{
int n,a=0,s=0,b,i;
cin>>n;
while(n!=0)
{
a=0;
s=0;
for(i=0;i<n;i++)
{
cin>>b;
if(b>a)//电梯上升
s+=(b-a)*6;
else if(b<a)//电梯下降
s+=(a-b)*4;
s+=5;
a=b;//记录电梯现在在几层
}
cout<<s<<endl;
cin>>n;
}
return 0;
}


运行结果:

Accepted10080MS1956K409 B
题解:

易错点在电梯停留时间,一定要放在if外,至于为什么,请思考:电梯从3层到3层需要的时间。这时电梯没有上升也没有下降(在if中s没有变化),但它依旧停留了一次,所以时间依旧应该+=5。

参考知识:

无。



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: