您的位置:首页 > 其它

Palindromes

2015-07-26 18:05 253 查看

http://acm.hdu.edu.cn/showproblem.php?pid=1318

Palindromes

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 787 Accepted Submission(s): 294


[align=left]Problem Description[/align]
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

Character  Reverse  Character  Reverse  Character  Reverse

A         A         M         M         Y         Y

B                   N                   Z         5

C                   O         O         1         1

D                   P                   2         S

E         3         Q                   3         E

F                   R                   4

G                   S         2         5         Z

H         H         T         T         6

I         I         U         U         7

J         L         V         V         8         8

K                   W         W         9

L         J         X         X


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

[align=left]Input[/align]
Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

[align=left]Output[/align]
For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

" -- is not a palindrome."
if the string is not a palindrome and is not a mirrored string

" -- is a regular palindrome."
if the string is a palindrome and is not a mirrored string

" -- is a mirrored string."
if the string is not a palindrome and is a mirrored string

" -- is a mirrored palindrome."
if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

[align=left]Sample Input[/align]

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA

[align=left]Sample Output[/align]

NOTAPALINDROME -- is not a palindrome. ISAPALINILAPASI -- is a regular palindrome. 2A3MEAS -- is a mirrored string. ATOYOTA -- is a mirrored palindrome.
用到了isalpha(ch) 判断是不是一个英文字符 在头文件cctype里

用到了strlen(s) 统计数组长度,在头文件cstring中

使用常量数组会简化代码

#include<iostream>
#include<string>
#include<cstring>
#include<cctype>
#include<cstdio>
const char* rev = "A   3  HIL JM O   2TUVWXY51SE Z  8 ";
const char* msg[] = {"not a palindrome","a regular palindrome","a mirrored string","a mirrored palindrome"};

char r(char ch)
{
if(isalpha(ch)) return rev[ch - 'A'];
return rev[ch - '0' +25];
}
int main()
{
char s[30];
while(~scanf("%s",s))
{
int len = strlen(s);
bool p = true;
bool m = true;
for(int i = 0 ;i < (len+1)/2 ; i++)
{
if(s[i]!=s[len-1-i])  p = false ;
if(r(s[i])!=s[len-1-i])  m = false;
}
printf("%s -- is %s.\n\n",s,msg[m*2+p]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: