您的位置:首页 > 其它

poj3267 The Cow Lexicon -DP

2015-07-26 13:55 417 查看
点击打开题目链接http://poj.org/problem?id=3267

The Cow Lexicon

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8722 Accepted: 4110
Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not
make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length
L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words
from the dictionary.

Input
Line 1: Two space-separated integers, respectively:
W and L

Line 2: L characters (followed by a newline, of course): the received message

Lines 3..W+2: The cows' dictionary, one word per line
Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output
2


题目大意是,输入一个字符串和一组单词,一组单词构成单词表,问:在字符串中至少去掉多少个单词,才能使字符串是由单词表中的单词组成。

#include<cstdio>
#include<cstring>

char s[610][30];
char str[310];
int dp[310];
int n,m;

int min(int a,int b)
{
return a=a<b?a:b;
}
int main()
{
while(~scanf("%d %d",&n,&m))
{
memset(dp,0,sizeof(dp));
scanf("%s",str);
for(int i=0;i<n;i++)
{
scanf("%s",s[i]);
}
dp[m]=0;
for(int i=m-1;i>=0;i--)
{
dp[i]=dp[i+1]+1;
for(int j=0;j<n;j++)
{
int len=strlen(s[j]);
if(len+i<=m && s[j][0]==str[i]) //首字匹配 且 这个单词有可能被匹配
{
int ps=i;
int pw=0;
while(ps<m)//从该点开始往后匹配
{
if(s[j][pw]==str[ps++])
{
pw++;
}
if(pw==len) //单词表中的这个单词全部匹配
{
dp[i]=min(dp[i],dp[ps]+(ps-i)-len); //更新dp[i]
break;
}
}
}
}
}
printf("%d\n",dp[0]) ;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: