您的位置:首页 > 其它

A + B Problem II

2015-07-26 12:02 225 查看

                            A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 261369    Accepted Submission(s): 50579


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

[align=left]Author[/align]
Ignatius.L
解题思路:这是关于大数相加的问题,用到数组,将字符串转化为整数,位对位进行相加,如果大于10时则要进位。
#include<stdio.h>
#include<string.h>
#define MAX 1010
int main()
{
char s1[MAX],s2[MAX];
int a[MAX],b[MAX],T,i,j,k=1,n;
scanf("%d",&T);
while(T--)
{
scanf("%s %s",s1,s2);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
n=strlen(s1)-1;
for(i=0,j=n;j>=0;i++,j--)
a[i]=s1[j]-'0';
n=strlen(s2)-1;
for(i=0,j=n;j>=0;i++,j--)
b[i]=s2[j]-'0';
for(i=0;i<MAX;i++)
{
a[i]+=b[i];
if(a[i]>=10)
{
a[i]-=10;
a[i+1]+=1;
}
}
printf("Case %d:\n",k++);
printf("%s + %s = ",s1,s2);
for(i=MAX-1;i>=0;i--)
if(a[i]!=0) break;
for(;i>=0;i--)
printf("%d",a[i]);
printf("\n");
if(T!=0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu Problem 1002