您的位置:首页 > 其它

A Simple Task

2015-07-26 11:54 274 查看

A Simple Task

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4313 Accepted Submission(s):
2372


[align=left]Problem Description[/align]
Given a positive integer n and the odd integer o and
the nonnegative integer p such that n = o2^p.

Example

For n =
24, o = 3 and p = 3.

Task

Write a program which for each data
set:

reads a positive integer n,

computes the odd integer o and
the nonnegative integer p such that n = o2^p,

writes the
result.

[align=left]Input[/align]
The first line of the input contains exactly one
positive integer d equal to the number of data sets, 1 <= d <= 10. The
data sets follow.

Each data set consists of exactly one line containing
exactly one integer n, 1 <= n <= 10^6.

[align=left]Output[/align]
The output should consists of exactly d lines, one line
for each data set.

Line i, 1 <= i <= d, corresponds to the i-th
input and should contain two integers o and p separated by a single space such
that n = o2^p.

[align=left]Sample Input[/align]

1

24

[align=left]Sample Output[/align]

3 3

#include<stdio.h>
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int a,c=0;
scanf("%d",&a);
while(a%2==0)
{
c++;
a/=2;
}
printf("%d %d\n",a,c);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: