您的位置:首页 > 其它

1001

2015-07-26 11:12 441 查看

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).In this problem, your task is to calculate SUM(n)
= 1 + 2 + 3 + ... + n. 

Input

The input will consist of a series of integers n, one integer per line. 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer. 

Sample Input

1

100 

Sample Output

1

5050

#include<stdio.h>
int main(){
int i, n, b = 0, s = 0;
while(scanf("%d", &n) != EOF){
s = 0;
for(i = 1; i <= n; i++){
s += i;
}
printf("%d\n\n", s);  //看清题目中的样例输出之间有空格;
}
return 0;
}


学习笔记:
Accepted (AC)  说明答案对了
Wrong Answer (WA) 说明错了
Time Limit Exceeded (TLE) 超时
Memory Limit Exceeded (MLE) 超内存
Compilation Error (CE) 编译错误
Presentation Error (PE) 格式错误 一般是空格和换行的问题
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: