您的位置:首页 > 其它

zoj2388 Beat the Spread!

2015-07-25 21:51 323 查看
Beat the Spread!

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the
absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

Sample Input

2

40 20

20 40

Sample Output

30 10

impossible

Source
University of Waterloo Local Contest 2005.02.05

分析:
水题。注意判断(s+d)%2==0就可以了。
ac代码:

#include <iostream>

#include<cstdio>

using namespace std;

int main()

{

int n,s,d;

int x,y;

scanf("%d",&n);

while(n--)

{

scanf("%d%d",&s,&d);

if(s>=d&&(s+d)%2==0)//注意判断(s+d)%2==0

printf("%d %d\n",(s+d)/2,(s-d)/2);

else

printf("impossible\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: