您的位置:首页 > 其它

BestCoder 1st Anniversary

2015-07-25 20:06 363 查看


Souvenir

Accepts: 1078

Submissions: 2366

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 262144/262144 K (Java/Others)

Problem Description

Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is p yuan
and the price for a set of souvenirs if q yuan.
There's m souvenirs
in one set.
There's n contestants
in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105),
indicating the number of test cases. For each test case:
There's a line containing 4 integers n,m,p,q (1≤n,m,p,q≤104).

Output

For each test case, output the minimum cost needed.

Sample Input

2
1 2 2 1
1 2 3 4


Sample Output

1
3

Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs.
For the second case, Soda can use 3 yuan to buy a souvenir.


BestCoder周年纪念赛,趁着还没结束,来一发水题题解(其实是卡题了(/ □ \)囧)

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int n,m,p,q,T,flag;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d",&n,&m,&p,&q);
        if(n<=m)
            flag = min(p*n,q);
        else
        {
            if(p<=q/m)
                flag = n*p;
            else {
                int x = n/m*q;
                int y = (n-n/m*m)*p;
                int z = (n/m+1)*q;
                flag = min(x+y,z);
            }
        }
        printf("%d\n",flag);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: