您的位置:首页 > 其它

九度oj 1201

2015-07-25 17:28 204 查看
题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。
输入:

    输入第一行包括一个整数n(1<=n<=100)。

    接下来的一行包括n个整数。
输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。

    每种遍历结果输出一行。每行最后一个数据之后有一个空格。
样例输入:
5
1 6 5 9 8

样例输出:
1 6 5 9 8
1 5 6 8 9
5 8 9 6 1

提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。
来源:
2005年华中科技大学计算机保研机试真题
#include<iostream>
using namespace std;
struct node{
node *lchild;
node *rchild;
int c;
}tree[110];
int loc;
node *create()
{
tree[loc].lchild=tree[loc].rchild=NULL;
return &tree[loc++];
}
void preorder(node *t)
{
cout<<t->c<<" ";
if(t->lchild!=NULL){
preorder(t->lchild);}
if(t->rchild!=NULL){
preorder(t->rchild);}
}
void inorder(node *t)
{
if(t->lchild!=NULL){
inorder(t->lchild);}
cout<<t->c<<" ";
if(t->rchild!=NULL){
inorder(t->rchild);}
}
void postorder(node *t)
{
if(t->lchild!=NULL){
postorder(t->lchild);}

if(t->rchild!=NULL){
postorder(t->rchild);}
cout<<t->c<<" ";
}
node *insert(node *t,int x)
{
if(t==NULL)
{
t=create();
t->c=x;
return t;
}
else if(x<t->c)
{
t->lchild=insert(t->lchild,x);
}
else if(x>t->c)
{
t->rchild=insert(t->rchild,x);
}
return t;
}
int main()
{
int n;
while(cin>>n)
{
loc=0;
node *t=NULL;
for(int i=0;i<n;i++)
{
int x;
cin>>x;
t=insert(t,x);
}
preorder(t);
cout<<endl;
inorder(t);
cout<<endl;
postorder(t);
cout<<endl;
}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: