您的位置:首页 > 其它

poj 2828 Buy Tickets (线段树 单节点 查询位置更新)

2015-07-25 11:34 423 查看
Buy Tickets

Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 15533Accepted: 7759
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped
the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of
N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of values
Posi and Vali in the increasing order ofi (1 ≤
i ≤ N). For each i, the ranges and meanings ofPosi and
Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind thePosi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue
was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the valueVali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output
77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



Source
POJ Monthly--2006.05.28, Zhu, Zeyuan

自己没有想到解法 看的网上思路,逆序插入比如1号在1的位置上,2号要在1号的位置后,三号也要在1的位置后,那么次序就是0 1 3 2 由于最后一个插入的人的位置一定是他

想要的位置,那我们逆序插入的时候必然先满足他,然后我们插入2号,本来2号要插入2的位置(因为他想在1的后面),但是被三号占了,还必须得满足三号,把他往后放。

最后插入1号的位置1.

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=200003;
int dict[INF];
struct Tree
{
    int left,right,num;
}tree[INF<<2];

int create(int root,int left,int right)
{
    tree[root].left=left;
    tree[root].right=right;
    if(left==right)
    {
         return tree[root].num=1;
    }
    int a,b,mid=(left+right)>>1;
    a=create(root<<1,left,mid);
    b=create(root<<1|1,mid+1,right);
    return tree[root].num=a+b;
}

void update(int root,int pos ,int val)
{

    if(tree[root].left==tree[root].right)
    {
        tree[root].num=0;dict[tree[root].left]=val;
        return ;
    }
    if(pos<=tree[root<<1].num)
        update(root<<1,pos,val);
    else
        update(root<<1|1,pos-tree[root<<1].num,val);
    tree[root].num=tree[root<<1].num+tree[root<<1|1].num;

}

int main()
{
    int n;
    while(cin>>n)
    {
        create(1,1,n);memset(dict,0,sizeof(dict));
        int pos[INF],val[INF];
        for(int i=0;i<n;i++)
            scanf("%d%d",&pos[i],&val[i]);
        for(int i=n-1;i>=0;i--)
        {
           update(1,++pos[i],val[i]);
        }
        for(int i=1;i<=n;i++)
        {
            printf("%d%c",dict[i],i==n? '\n':' ');
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: