您的位置:首页 > 其它

hdoj1002A + B Problem II

2015-07-24 21:05 399 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 261114    Accepted Submission(s): 50520


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<stdio.h>
#include<string.h>
#define N 1010
int a
,b
;
char str1
,str2
;

int main()
{
int len1,len2;
int i,j,n;
scanf("%d",&n);
for(int m=0;m<n;m++)
{

scanf("%s",str1);
scanf("%s",str2);
printf("Case %d:\n%s + %s = ",m+1,str1,str2);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
len1=strlen(str1);

for (j=0,i=len1-1;i>=0;i--)
{
a[j++]=str1[i]-'0';

}
len2=strlen(str2);
for(j=0,i=len2-1;i>=0;i--)
{
b[j++]=str2[i]-'0';
}
for (i=0;i<N;i++)
{
a[i]+=b[i];
if(a[i]>=10)
{   a[i]-=10;
a[i+1]++;

}
}
for (i=N;(i>=0)&&(a[i]==0);i--);

if(i>=0)
for (j=0;i>=0;i--)
printf("%d",a[i]);
else printf("0");
if(m!=n-1)
printf("\n\n");
else
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: