您的位置:首页 > 其它

PAT (Advanced Level) 1037. Magic Coupon (25) 求两数组元素相乘最大和,排序

2015-07-24 20:21 399 查看
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product
for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon
2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC,
NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43

将两个数组都升序排列后,从头开始负负相乘,从尾开始正正相乘,遇到异号break。

/*2015.7.24cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
int a[100002],b[100002];
int main(){
int n,m,sum=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",a+i);
scanf("%d",&m);
for(int i=0;i<m;i++)
scanf("%d",b+i);
sort(a,a+n);
sort(b,b+m);
for(int i=0;i<n&&i<m;i++){
if(a[i]<0&&b[i]<0)
sum+=a[i]*b[i];
else
break;
}
for(int i=0;i<n&&i<m;i++){
if(a[n-i-1]>0&&b[m-i-1]>0)
sum+=a[n-i-1]*b[m-i-1];
else
break;
}
printf("%d\n",sum);
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: