您的位置:首页 > 其它

POJ 3076 Sudoku

2015-07-24 19:02 344 查看
Description

A Sudoku grid is a 16x16 grid of cells grouped in sixteen 4x4 squares, where some cells are filled with letters from A to P (the first 16 capital letters of the English alphabet), as shown in figure 1a. The game is to fill all the empty grid cells with letters
from A to P such that each letter from the grid occurs once only in the line, the column, and the 4x4 square it occupies. The initial content of the grid satisfies the constraints mentioned above and guarantees a unique solution.



Write a Sudoku playing program that reads data sets from a text file.

Input

Each data set encodes a grid and contains 16 strings on 16 consecutive lines as shown in figure 2. The i-th string stands for the i-th line of the grid, is 16 characters long, and starts from the first position of the line. String characters are from the set
{A,B,…,P,-}, where – (minus) designates empty grid cells. The data sets are separated by single empty lines and terminate with an end of file.

Output

The program prints the solution of the input encoded grids in the same format and order as used for input.

Sample Input

--A----C-----O-I
-J--A-B-P-CGF-H-
--D--F-I-E----P-
-G-EL-H----M-J--
----E----C--G---
-I--K-GA-B---E-J
D-GP--J-F----A--
-E---C-B--DP--O-
E--F-M--D--L-K-A
-C--------O-I-L-
H-P-C--F-A--B---
---G-OD---J----H
K---J----H-A-P-L
--B--P--E--K--A-
-H--B--K--FI-C--
--F---C--D--H-N-


Sample Output

FPAHMJECNLBDKOGI
OJMIANBDPKCGFLHE
LNDKGFOIJEAHMBPC
BGCELKHPOFIMAJDN
MFHBELPOACKJGNID
CILNKDGAHBMOPEFJ
DOGPIHJMFNLECAKB
JEKAFCNBGIDPLHOM
EBOFPMIJDGHLNKCA
NCJDHBAEKMOFIGLP
HMPLCGKFIAENBDJO
AKIGNODLBPJCEFMH
KDEMJIFNCHGAOPBL
GLBCDPMHEONKJIAF
PHNOBALKMJFIDCEG
IAFJOECGLDPBHMNK

建图+dlx
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll maxn=20005;
const ll size=20;
int n,m,x,y,T,tot,p[maxn][3],a[size][size];
char s[size][size];

inline void read(int &ret)
{
	char c;
	do { c = getchar();
	} while(c < '0' || c > '9');
	ret = c - '0';
	while((c=getchar()) >= '0' && c <= '9')
	ret = ret * 10 + ( c - '0' );
}

struct DLX
{
	int L[maxn],R[maxn],U[maxn],D[maxn];
	int row[maxn],col[maxn],ans[maxn],cnt[maxn];
	int n,m,num,sz;
	void add(int now,int l,int r,int u,int d,int x,int y)
	{
		L[now]=l;	R[now]=r;	U[now]=u;
		D[now]=d;   row[now]=x;  col[now]=y;
	}
	void reset(int n,int m)
	{
		this->n=n;	this->m=m;
		for (int i=0;i<=m;i++)
		{
			add(i,i-1,i+1,i,i,0,i);
			cnt[i]=0;
		}
		L[0]=m; 	R[m]=0; 	sz=m+1;
	}
	void insert(int x,int y)
	{
		int ft=sz-1;	
		if (row[ft]!=x)
		{
			add(sz,sz,sz,U[y],y,x,y);
			U[D[sz]]=sz; D[U[sz]]=sz;
		}
		else 
		{
			add(sz,ft,R[ft],U[y],y,x,y);
			R[L[sz]]=sz; L[R[sz]]=sz;
			U[D[sz]]=sz; D[U[sz]]=sz;
		}
		++cnt[y];	++sz;
	}
	void remove(int now)
	{
		R[L[now]]=R[now];
		L[R[now]]=L[now];
		for (int i=D[now];i!=now;i=D[i])
			for (int j=R[i];j!=i;j=R[j])
			{
				D[U[j]]=D[j];
				U[D[j]]=U[j];
				--cnt[col[j]];
			}
	}
	void resume(int now)
	{	
		for (int i=U[now];i!=now;i=U[i])
			for (int j=L[i];j!=i;j=L[j])
			{
				D[U[j]]=j;
				U[D[j]]=j;
				++cnt[col[j]];
			}
		R[L[now]]=now;
		L[R[now]]=now;
	}
	bool dfs(int x)
	{
		if (!R[0]) {num=x; return true;}
		int now=R[0];
		for (int i=now;i!=0;i=R[i])
			if (cnt[now]>cnt[i]) now=i;
		remove(now);
		for (int i=D[now];i!=now;i=D[i])
		{
			ans[x]=row[i];
			for (int j=R[i];j!=i;j=R[j]) remove(col[j]);
			if (dfs(x+1)) return true;
			for (int j=L[i];j!=i;j=L[j]) resume(col[j]);
		}
		resume(now);
		return false;
	}
	void display()
	{
		for (int i=0;i<num;++i) 
		{
			s[p[ans[i]][0]][p[ans[i]][1]]=p[ans[i]][2]+'A'-1;
		}
		for (int i=1;i<=16;i++) puts(s[i]+1);
		putchar(10);
	}
}dlx;

int check(int x,int y)
{
	x=(x-1)/4;
	y=(y-1)/4;
	return 4*x+y;
}

void insert(int x,int y,int z)
{
	p[++tot][0]=x;
	p[tot][1]=y;
	p[tot][2]=z;
	dlx.insert(tot,16*(x-1)+y);
	dlx.insert(tot,256+16*(x-1)+z);
	dlx.insert(tot,512+16*(y-1)+z);
	dlx.insert(tot,768+16*check(x,y)+z);
}

int main()
{
	int c[size][size],r[size][size],u[size][size];
	while (~scanf("%s",s[1]+1))
	{
		tot=0;
		for (int i=2;i<=16;++i) scanf("%s",s[i]+1);
		memset(c,0,sizeof(c));
		memset(r,0,sizeof(r));
		memset(u,0,sizeof(u));
		dlx.reset(4096,1024);
		for (int i=1;i<=16;++i)
			for (int j=1;j<=16;++j) 
			{
				if (s[i][j]=='-') a[i][j]=0;
				else a[i][j]=s[i][j]-'A'+1;
				if (a[i][j]) 
				{
					insert(i,j,a[i][j]);
					c[i][a[i][j]]=r[j][a[i][j]]=u[check(i,j)][a[i][j]]=1;
				}
			}
		for (int i=1;i<=16;++i)
			for (int j=1;j<=16;++j) 
				for (int k=1;k<=16;++k)
					if (a[i][j]+c[i][k]+r[j][k]+u[check(i,j)][k]<1) insert(i,j,k);
		if (dlx.dfs(0)) dlx.display();
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: