您的位置:首页 > 其它

HDU 1171 Big Event in HDU

2015-07-24 10:41 183 查看

欢迎参加——BestCoder周年纪念赛(高质量题目+多重奖励)


Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28468 Accepted Submission(s): 10023


[align=left]Problem Description[/align]
Nowadays,
we all know that Computer College is the biggest department in HDU.
But, maybe you don't know that Computer College had ever been split into
Computer College and Software College in 2002.
The splitting is
absolutely a big event in HDU! At the same time, it is a trouble thing
too. All facilities must go halves. First, all facilities are assessed,
and two facilities are thought to be same if they have the same value.
It is assumed that there is N (0<N<1000) kinds of facilities
(different value, different kinds).

[align=left]Input[/align]
Input
contains multiple test cases. Each test case starts with a number N (0
< N <= 50 -- the total number of different facilities). The next N
lines contain an integer V (0<V<=50 --value of facility) and an
integer M (0<M<=100 --corresponding number of the facilities)
each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

[align=left]Output[/align]
For
each case, print one line containing two integers A and B which denote
the value of Computer College and Software College will get
respectively. A and B should be as equal as possible. At the same time,
you should guarantee that A is not less than B.

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1

[align=left]Sample Output[/align]

20 10
40 40

[align=left]Author[/align]
lcy

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 2602 1203 2159 2955 2844

#include<stdio.h>
#include<string.h>
int c[250005],temp[250005];
int num[55],cost[55];
int main(){
int n;
while(scanf("%d",&n)!=EOF){
if(n<0)
break;
memset(c,0,sizeof(c));
memset(temp,0,sizeof(temp));
memset(num,0,sizeof(num));
memset(cost,0,sizeof(cost));
int sum=0;
for(int i=0;i<n;i++){
scanf("%d%d",&cost[i],&num[i]);
sum+=cost[i]*num[i];
}

int total=sum/2;
for(int i=0;i<=num[0];i++){
c[i*cost[0]]=1; 。///初始化的时候特别注意
}

for(int i=1;i<n;i++){
for(int j=0;j<=sum;j++){
for(int k=0;k+j<=sum&&k/cost[i]<=num[i];k+=cost[i])
temp[k+j]+=c[j];
}

for(int ii=0;ii<=sum;ii++){
c[ii]=temp[ii];
temp[ii]=0;

}
}
int i;
for( i=total;i>=0;i--){
if(c[i])
break;
}
printf("%d %d\n",sum-i,i);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: