您的位置:首页 > 其它

[贪心] HDU1009 FatMouse' Trade

2015-07-24 10:22 351 查看
A - FatMouse’ Trade

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

设一个结构体,按单价从大到小排个序,依次取出,直到将m减到0为止就可以了。

#include <cstdio>
#include<iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const double eps = 1e-8;
const int MAXN = 200020;

struct node
{
int javaBean;
int catFood;
double percent;
};
node room[MAXN];
bool cmp(node a,node b)
{
return a.percent > b.percent;
}

int main()
{
int M,N;
while(scanf("%d%d",&M,&N) != EOF)
{
if (M==-1 && N == -1) break;
for(int i = 0 ; i < N; i++)
{
scanf("%d%d",&room[i].javaBean,&room[i].catFood);
room[i].percent = (double) room[i].javaBean / room[i].catFood;
}
sort(room,room+N,cmp);
double ans = 0;
for(int i = 0;i<N;i++)
{
if (M > room[i].catFood)
{
M -= room[i].catFood;
ans += room[i].javaBean;
}
else
{
ans += room[i].percent * M;
M = 0;
break;
}
}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: