您的位置:首页 > 其它

hdu1860 统计字符(水题)

2015-07-23 19:37 162 查看


统计字符

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8570 Accepted Submission(s): 5424



Problem Description

统计一个给定字符串中指定的字符出现的次数



Input

测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串。注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一。当读到'#'时输入结束,相应的结果不要输出。



Output

对每个测试用例,统计第1行中字符串的每个字符在第2行字符串中出现的次数,按如下格式输出:

c0 n0

c1 n1

c2 n2

...

其中ci是第1行中第i个字符,ni是ci出现的次数。



Sample Input

I
THIS IS A TEST
i ng
this is a long test string
#




Sample Output

I 2
i 3
  5
n 2
g 2 
注:第2个测试用例中,空格也是被统计的字符之一。




Source

浙大计算机研究生复试上机考试-2007年



Recommend

lcy | We have carefully selected several similar problems for you: 1859 1862 1861 1864 1235



Statistic | Submit | Discuss | Note

#include <stdio.h>
#include <string.h>
int main()
{
	char str1[8],str2[85];
	while(gets(str1)!=NULL)
	{
		if(str1[0]=='#')
		break;
		gets(str2);
		int len1=strlen(str1);
		int len2=strlen(str2);
		for(int i=0;i<len1;i++)
		{
			int sum=0;
			for(int j=0;j<len2;j++)
			if(str1[i]==str2[j])
			sum++;
			printf("%c %d\n",str1[i],sum);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: