您的位置:首页 > 其它

HDOJ 1003 Max Sum(动态规划)

2015-07-23 17:56 351 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 176237 Accepted Submission(s): 41047



[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6


[align=left]Author[/align]
Ignatius.L

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1176 1087 1069 2084 1058

#include<stdio.h>
#include<string.h>
int main(){
int n,i,a[100001],t=1,m;
int thissum,maxsum,star,end,mark;
//目前的和,历史最大和,最大和开始点,最大和终止点,标记(为定开始点用)
scanf("%d",&n);
while(n--){
memset(a,0,sizeof(a));//初始化
scanf("%d",&m);
for(i=0;i<m;i++){
scanf("%d",&a[i]);
}
thissum=0; maxsum=a[0];
star=1; end=1; mark=1;//从第一个数开始
for(i=0;i<m;i++){
thissum+=a[i];//目前和要加上当前数
if(thissum>maxsum){
maxsum=thissum;
star=mark;//其实mark不变,开始位置就不变
end=i+1;//结束位置是当前
}//发现历史最大和比当前和小了,最大连续子序列不唯一,则输出序号i和j最小的那个 ,所以不 =
if(thissum<0){
mark=i+2;//标记后一个数,为star做准备
thissum=0; //当前最大值清理
}//目前最大和小于0,就不是最大了,要是等于0或大于0还好说
}
printf("Case %d:\n%d %d %d\n",t++,maxsum,star,end);
if(n) printf("\n");//格式
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: