您的位置:首页 > 其它

杭电 HDU 1233 还是畅通工程 (dij)

2015-07-23 16:21 387 查看

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31479 Accepted Submission(s): 14142



Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。



Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。

当N为0时,输入结束,该用例不被处理。



Output
对每个测试用例,在1行里输出最小的公路总长度。



Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0




Sample Output
3
5

HintHint 
Huge input, scanf is recommended.

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF = 101;
int F[INF];
int n,ans;

struct edges
{
    int u,v,w;
} per[INF*INF];

bool cmp(edges a,edges b)
{
    return a.w<b.w;
}

void init()
{
    for(int i = 1; i <= n; i++)
    {
        F[i] = i;
    }
}
int Find(int x)
{
    return x==F[x]? x:Find(F[x]);
}
int main()
{
    while(cin>>n,n)
    {
        ans=0;
        int m = n*(n-1)/2;
        for(int i = 0; i<m; i++)
            scanf("%d%d%d",&per[i].u,&per[i].v,&per[i].w);
        sort(per,per + m,cmp);
        init();
        int count = 0;
        for(int i=0; i<m; i++)
        {
            int tx=Find(per[i].u);
            int ty=Find(per[i].v);
            if(tx != ty)
                {
                     count++;
                  F[tx]=ty;
                    ans+=per[i].w;
                    if(count==n-1)
                        break;
                }

        }
        cout<<ans<<endl;
    }

    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: