您的位置:首页 > 其它

1054. The Dominant Color (20)

2015-07-23 13:17 295 查看
题目如下:

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more
than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224).
It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:
24


题目要求从一个线性表中找出出现次数最多的元素,可以使用map统计每个元素的出现次数,然后动态的统计当前出现次数最多的。

#include <iostream>
#include <map>
#include <stdio.h>

using namespace std;

int main()
{
int maxCnt = -1;
int maxColor = -1;
map<int,int> colorMap;
int M,N;
cin >> M >> N;
int color;
for(int i = 0; i < N; i++){
for(int j = 0; j < M; j++){
scanf("%d",&color);
if(colorMap.find(color) == colorMap.end()){
colorMap[color] = 1;
}else{
colorMap[color]++;
}
if(maxCnt < colorMap[color]){
maxCnt = colorMap[color];
maxColor = color;
}
}
}
cout << maxColor << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: