您的位置:首页 > 其它

poj 1456 Supermarket

2015-07-23 10:57 302 查看
http://poj.org/problem?id=1456

Supermarket
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time
for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is
Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product.
White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10


Sample Output

80
185


Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题目大意:

有N件商品,分别给出商品的价值和销售的最后期限,只要在最后日期之前销售处,就能得到相应的利润,并且销售该商品需要1天时间。

问销售的最大利润

解题思路:
可以用并查集来做,将商品的价值从大到小排序,然后为了寻找第一个能占用的日期,我们可以把最后期限作为根节点,并把它连接到昨天(昨天空闲),如果根节点被占用,我们就向前查找,找到的根节点就是当然第一个没被占用的日期,这样就可以了。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 250000
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8

int n, f
;

struct node
{
    int x, y;
}stu
;

int Find (int x)
{
    if (x != f[x]) f[x] = Find (f[x]);
    return f[x];
}

int cmp (node a, node b)
{
    if (a.x > b.x) return 1;
    else return 0;
}

int main ()
{
    while (cin >> n)
    {
        for (int i=0; i<n; i++)
            cin >> stu[i].x >> stu[i].y;

        sort (stu, stu+n, cmp);

        for (int i=1; i<=10005; i++)
            f[i] = i;

        int sum = 0;

        for (int i=0; i<n; i++)
        {
            int xx = Find (stu[i].y);
            if (xx > 0)
            {
                sum += stu[i].x;
                f[xx] = xx - 1;
            }
        }

        cout << sum << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: