您的位置:首页 > 其它

hdu2199_Can you solve this equation?

2015-07-23 08:45 239 查看
Can you solve this equation?
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4


Sample Output

1.6152
No solution!


这个题二分比较明显,但是二分法要注意返回的值,返回不同的值有精度问题。

#include <stdio.h>

#include <math.h>

double an(double x)

{

return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;

}

double bs(double low,double high,double y)

{

double mid;

while(high-low>1e-7)

{

mid=(high+low)/2;

if(an(mid) > y) high=mid;

else low=mid;

}

return high;

}

int main()

{

int t;

scanf("%d",&t);

while(t--)

{

double y;

scanf("%lf",&y);

if(y<an(0)||y>an(100.0))

printf("No solution!\n");

else

printf("%.4lf\n",bs(0,100,y));

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: