您的位置:首页 > 其它

zoj1241

2015-07-23 02:02 323 查看
ZOJ  1241

Geometry Made Simple
Time Limit: 2 Seconds     
Memory Limit: 65536 KB
Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c.
This is called Pythagora's Law.

Here we consider the problem of computing the length of the third side, if two are given.



Input
The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal
to -1 (the 'unknown' side), the others are positive (the 'given' sides).
A description having a=b=c=0 terminates the input.

Output
For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output the length
of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.
Print a blank line after each test case.

Sample Input
3 4 -1

-1 2 7

5 -1 3

0 0 0


Sample Output

Triangle #1

c = 5.000

Triangle #2

a = 6.708

Triangle #3

Impossible.

My solution:

/*注意:每行第三个数字是c边且为最长边,而且满足 a*a+b*b=c*c ,否则不成立*/

#include<stdio.h>
#include<math.h>
int main()

{
int i=0;
double a,b,c;
while(scanf("%lf%lf%lf",&a,&b,&c)==3&&(a||b||c))
{
i=i+1;
if(c!=-1)
{
if((a*a+b*b)>(c*c+1))
{
printf("Triangle #%d\n",i);/*Tringle与#之间有空格*/
printf("Impossible.\n\n"); /*Impossible后面有一点*/</span>
}
else if(a==-1)
{
printf("Triangle #%d\n",i);
printf("a = %.3lf\n\n",sqrt(c*c-b*b));/*“a”与“=”之间有空格,“=”与“%”之间也有空格*/
}
else
{
printf("Triangle #%d\n",i);
printf("b = %.3lf\n\n",sqrt(c*c-a*a));
}
}
else
{
printf("Triangle #%d\n",i);
printf("c = %.3lf\n\n",sqrt(b*b+a*a));
}
}
return 0;
}
/*特别要注意输出格式,这道题花费太多时间才把格式错误找出来*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: