您的位置:首页 > 其它

BUY LOW, BUY LOWER poj1952

2015-07-22 21:38 330 查看
Description

The advice to “buy low” is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems’ advice:

“Buy low; buy lower”

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:

Day 1 2 3 4 5 6 7 8 9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87

The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:

Day 2 5 6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.

Output

Two integers on a single line:

The length of the longest sequence of decreasing prices

The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they “look the same” when the successive prices are compared. Thus, two different sequence of “buy” days could produce the same string of decreasing prices and be counted as only a single solution.

Sample Input

12

68 69 54 64 68 64 70 67 78 62

98 87

Sample Output

4 2

(1)题意:给一串数字,问最大递减子串有多少种?

解法:dp 用两个数组,一个记录长度,一个记录种数。特别注意两个数相同的时候。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int a[5005];
int main()
{
int n,i;
while(scanf("%d",&n)==1)
{
int dp[5005];
int cnt[5005]={0};
int maxlen=0;
int i,j;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
dp[i]=1;
cnt[i]=1;
}
for(i=1;i<n;i++)
{
for(j=i-1;j>=0;j--)
{
if(a[i]<a[j]) //降序的
{
if(dp[j]+1>dp[i])  //前边有更长的子串(或相同长)
{
dp[i]=dp[j]+1;
cnt[i]=cnt[j];  //多少个到J就有多少个到i
}
else
{
if(dp[j]+1==dp[i]) //i比j长一
{
cnt[i]=cnt[i]+cnt[j];  //多少种到J和到i就有两相加
}
}
}
else
{
if(a[i]==a[j])  //前边有相同的,那么后来的相同的就为0,此后不在计算他
{
if(dp[i]==1) cnt[i]=0;
break;
}
}
}
}
int time=0;
for(i=0;i<n;i++)
{
//  printf("%2d ",dp[i]);
maxlen=max(maxlen,dp[i]); //最长子串
}
//printf("\n");
for(i=0;i<n;i++)
{
if(dp[i]==maxlen) time=time+cnt[i];  //相同路径+
// printf("%2d ",cnt[i]);
}
//printf("\n");
printf("%d %d\n",maxlen,time);
}
return 0;
}

/*
12
数据   68 69 54 64 68 64 70 67 78 62 98 87
dp[i]  1  1  2  2  2  3  1  3  1  4  1  2
cnt[i] 1  1  2  2  1  1  1  1  1  2  1  1

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: