您的位置:首页 > 其它

hd2137

2015-07-22 20:47 218 查看

circumgyrate the string

[b]Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

[/b]

[align=left]Problem Description[/align]
Give you a string, just circumgyrate. The number N means you just circumgyrate the string N times, and each time you circumgyrate the string for 45 degree anticlockwise.

[align=left]Input[/align]
In each case there is string and a integer N. And the length of the string is always odd, so the center of the string will not be changed, and the string is always horizontal at the beginning. The length of the string will not exceed
80, so we can see the complete result on the screen.

[align=left]Output[/align]
For each case, print the circumgrated string.

[align=left]Sample Input[/align]

asdfass 7


[align=left]Sample Output[/align]

a
s
d
f
a
s
s 题目大意就是一字符串,嗯,长度总为奇数,以中间的字符为轴逆时针旋转,每次旋转45度。 不造有木有可以不用从0到7一个一个写的方法,挺麻烦,嗯,注意n可以为负 
<pre name="code" class="html">#include<stdio.h>
#include<string.h>
int main()
{
int n,i,j,lens;
char s[100];
while(~scanf("%s %d",s,&n))
{

n=n%8;
if(n<0)n+=8;
lens=strlen(s);
if(n==0)printf("%s\n",s);
else if(n==1)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<lens-i-1)printf(" ");
else if(j==lens-i-1)printf("%c",s[lens-i-1]);
}
printf("\n");
}
}
else if(n==2)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<(lens-1)/2)printf(" ");
else if(j==(lens-1)/2)printf("%c",s[lens-1-i]);
}
printf("\n");
}
}
else if(n==3)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<i)printf(" ");
else if(j==i)printf("%c",s[lens-i-1]);
}
printf("\n");
}
}
else if(n==4)
{
for(i=lens-1;i>=0;i--)printf("%c",s[i]);
printf("\n");
}
else if(n==5)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<lens-i-1)printf(" ");
else if(j==lens-i-1)printf("%c",s[i]);
}
printf("\n");
}
}
else if(n==6)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<(lens-1)/2)printf(" ");
else if(j==(lens-1)/2)printf("%c",s[i]);
}
printf("\n");
}
}
else if(n==7)
{
for(i=0;i<lens;++i)
{
for(j=0;j<lens;++j)
{
if(j<i)printf(" ");
else if(j==i)printf("%c",s[i]);
}
printf("\n");
}
}
}
return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: