您的位置:首页 > 其它

poj 2386

2015-07-22 18:18 239 查看
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer
John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.       

Given a diagram of Farmer John's field, determine how many ponds he has.     

Input

       * Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

       * Line 1: The number of ponds in Farmer John's field.     

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.


Sample Output

3


Hint

OUTPUT DETAILS:       

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
题意:
'W'表示积水,‘.’表示没有积水,上下左右对角表示连通的(八连通),连通的部分称为一个水洼给你一个图,要你求出水洼个数。
思路:
用DFS,进行递归,遇到’W标记起来,下次不再检索。循环即可。
代码:
#include<cstdio>
using namespace std;
const int maxn=105;
int N,M;
char field[maxn][maxn];
void dfs(int x,int y)
{
field[x][y]='.';
for(int dx=-1; dx<=1; dx++)
{

for(int dy=-1; dy<=1; dy++)
{
int nx=x+dx,ny=y+dy;
if(nx>=0&&nx<N&&ny>=0&&ny<M&&field[nx][ny]=='W')
dfs(nx,ny);

}
}
return ;
}
int main()
{
int sum=0;
scanf("%d%d",&N,&M);

for(int i=0; i<N; i++)
scanf("%s",&field[i]);//不能用scanf("%s",&field[i][j]),scanf会读回车,会乱了
for(int i=0; i<N; i++)
{
for(int j=0; j<M; j++)
if(field[i][j]=='W')
{
dfs(i,j);
sum++;
}
}
printf("%d\n",sum);

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: