您的位置:首页 > 其它

2015多校联赛 ——HDU5288(数学)

2015-07-22 17:50 323 查看


OO’s Sequence

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 449 Accepted Submission(s): 158



Problem Description

OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know

∑i=1n∑j=inf(i,j) mod (10^9+7).



Input

There are multiple test cases. Please process till EOF.

In each test case:

First line: an integer n(n<=10^5) indicating the size of array

Second line:contain n numbers ai(0<ai<=10000)



Output

For each tests: ouput a line contain a number ans.



Sample Input

5
1 2 3 4 5




Sample Output

23




Source

2015 Multi-University Training Contest 1

求在[a , b] 中有多少个i 满足找不到另一个数j 使,a[i] % a[j] = 0

用L[],R[]分别记录左右离起最近的因子,ans+=(R[i]-i+1)*(i-L[i]+1)/2 %MOD

//自己并没有想到怎么做 (╯▽╰)

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std ;
const int maxn = 100010 ;
const int mod = 1e9+7 ;
int a[maxn];
long long  last[maxn] ;
long long pre[maxn] ;
long long  l[maxn] ;
long long r[maxn] ;
int  main()
{
    //freopen("1001.txt" ,"r" ,stdin) ;
    int n;
    while(~scanf("%d",&n))
    {
        memset(pre,0,sizeof(pre));
        memset(last,0,sizeof(last));
        for(int i = 1;i <= n;i++)
        {
            l[i] = 1;
            r[i] = n;
            scanf("%d",&a[i]);
            for(int j = a[i];j < 10001;j+=a[i])
            {
                if(pre[j] && r[pre[j]] == n)
                    r[pre[j]] = i-1;
                pre[a[i]] = i;
            }
        }

        for(int i = n;i >=1;i--)
        {
            for(int j = a[i];j < 10001;j+=a[i])
            {
                if(last[j] && l[last[j]]==1)
                    l[last[j]] = i+1;
                last[a[i]] = i;
            }
        }
        long long ans = 0;
        for(long long int i = 1;i <= n;i++)
            ans= (ans+(((i-l[i]+1)%mod)*((r[i] - i +1)%mod))%mod)%mod;
        printf("%I64d\n",ans);
    }
    return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: