您的位置:首页 > 其它

PAT (Advanced Level) 1020. Tree Traversals (25) 给定后序中序,递归建树

2015-07-22 10:37 375 查看
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:
4 1 6 3 5 7 2

给定后序遍历和中序遍历,递归创建树。层序遍历。

/*2015.7.22cyq*/
#include <iostream>
#include <vector>
#include <queue>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct TNode{
int val;
TNode* left;
TNode* right;
TNode(int x):val(x),left(nullptr),right(nullptr){}
};
//利用给定的两个序列递归建树
TNode* recur(const vector<int> &post,const vector<int> &in,int pb,int pe,int ib,int ie){
if(pb>pe)
return nullptr;
TNode* root=new TNode(post[pe]);
int mid=ib;
while(in[mid]!=root->val)
mid++;
int lt=mid-ib;//左子树结点数

root->left=recur(post,in,pb,pb+lt-1,ib,mid-1);
root->right=recur(post,in,pb+lt,pe-1,mid+1,ie);

return root;
}

vector<int> levelOrder(TNode* root){
vector<int> result;
if(root==nullptr)
return result;
queue<TNode*> cur,next;
cur.push(root);
while(!cur.empty()){
while(!cur.empty()){
TNode* tmp=cur.front();
cur.pop();
result.push_back(tmp->val);
if(tmp->left!=nullptr)
next.push(tmp->left);
if(tmp->right!=nullptr)
next.push(tmp->right);
}
swap(cur,next);
}
return result;
}

int main(){
int N;
cin>>N;
vector<int> post,in;
int x;
for(int i=0;i<N;i++){
cin>>x;
post.push_back(x);
}
for(int i=0;i<N;i++){
cin>>x;
in.push_back(x);
}
TNode* root=recur(post,in,0,N-1,0,N-1);
vector<int> result=levelOrder(root);

cout<<result[0];
for(auto it=result.begin()+1;it!=result.end();++it)
cout<<" "<<*it;
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: