您的位置:首页 > 其它

hdoj 3367 Pseudoforest 【伪森林】 【并查集判断环 + 最大生成树】

2015-07-22 10:37 651 查看

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2126 Accepted Submission(s): 828

Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest
of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.



Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line
consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.

The last test case is followed by a line containing two zeros, which means the end of the input.



Output
Output the sum of the value of the edges of the maximum pesudoforest.



Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0




Sample Output
3
5



伪森林的定义
1,一个无向图;
2,它的所有连通分量最多只有一个环;
伪森林的大小取决于图中所有边的边权之和。

题意:给你一个无向图,让你求出图中最大的伪森林。

这道题用到最大生成树的实现方法(kruskal)。关键在于并查集部分的处理

一:两点不在一颗树上
1,两点都不在环里,直接增边;
2,两点只有一个在环里,增边后并标记两点都在环里面;
3,两点都在环里面,增边后生成树一定会有至少两个环,不符;

二:两点在一棵树上
1,两点都不在环里,直接增边,并标记;
2,两点只有一个在环里,增边后生成树会有至少两个环,不符;
3,两点都在环里面,增边后生成树一定会有至少两个环,不符;

建议上面的处理过程,自己画个图 模拟下。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 10000+10
#define MAXM 100000+10
using namespace std;
struct Edge
{
	int from, to, val;
}num[MAXM];
int N, M;
int set[MAXN];
int vis[MAXN];//表示该点是否在一个环里面 
bool cmp(Edge a, Edge b)
{
	return a.val > b.val;
}
int find(int p)
{
	int t;
	int child = p;
	while(p != set[p])
	p = set[p];
	while(child != p)
	{
		t = set[child];
		set[child] = p;
		child = t;
	}
	return p;
}
void solve()
{
	sort(num, num+M, cmp);
	int ans = 0;
	for(int i = 0; i < M; i++) 
	{
		int x = find(num[i].from);
		int y = find(num[i].to);
		if(x != y)//不在同一颗树上
		{
			if(!vis[x] && !vis[y])//都不在环里面 
			{
				ans += num[i].val;
				set[x] = y;
			}
			else if(!vis[x] || !vis[y])//一个在环里面 一个不在
			{
				ans += num[i].val;
				vis[x] = vis[y] = 1;//标记在环里面 
				set[x] = y;
			} 
		} 
		else //在同一颗树上 
		{
			if(!vis[x] && !vis[y])//都不在环里面 
			{
				vis[x] = vis[y] = 1;
				ans += num[i].val;
			} 
		} 
	}
	printf("%d\n", ans); 
}
int main()
{
	while(scanf("%d%d", &N, &M), N||M)
	{
		for(int i = 0; i < N; i++) set[i] = i, vis[i] = 0;
		for(int i = 0; i < M; i++) scanf("%d%d%d", &num[i].from, &num[i].to, &num[i].val);
		solve();
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: