您的位置:首页 > 其它

POJ 1936:全在其中(All in All )

2015-07-21 23:11 761 查看



All in All

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 2
[align=left]Problem Description[/align]
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are
generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

 

[align=left]Input[/align]
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
 

[align=left]Output[/align]
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
 

[align=left]Sample Input[/align]

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

 

[align=left]Sample Output[/align]

Yes
No
Yes
No

中文版:

描述
你设计了一个新的加密技术,可以用一种聪明的方式在一个字符串的字符间插入随机的字符串从而对信息进行编码。由于专利问题,我们将不会详细讨论如何在原有信息中产生和插入字符串。不过,为了验证你的方法,有必要写一个程序来验证原来的信息是否全在最后的字符串之中。

给定两个字符串s和t,你需要判断s是否是t的“子列”。也就是说,如果你去掉t中的某些字符,剩下字符将连接而成为s。

输入
输入包括多个测试样例。每一个都是由空格分隔的由字母数字ASCII字符组成的两个特定的字符串s和t。s和t的长度不超过100000。
输出
对于每个测试样例,如果s是t的“子列”,则输出”Yes”,否则输出”No”
[align=left]Sample Input[/align]

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

 

[align=left]Sample Output[/align]

Yes
No
Yes
No




注:此题为:POJ 1936:全在其中

说明:在母串中一直循环,字串的循环,判断时,母串从前往后,不回头,保证顺序

已AC源代码:

#include<stdio.h>
#include<string.h>
#define M 100000
int main()
{
char ch1[M+1],ch2[M+1];
while(~scanf("%s %s",ch1,ch2))
{
int len1,len2,i,j,k;
len1=strlen(ch1);
len2=strlen(ch2);
k=j=0;
for(i=0;i<len1;++i)
{
if(j==len2)
break;
for(;j<len2;j++) //j一直加,从而使顺序不变
{
if(ch1[i]==ch2[j])
{
k++;
j++;
break;
}
}
}
if(k==len1)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息