您的位置:首页 > 其它

To and Fro

2015-07-21 21:22 274 查看

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5481    Accepted Submission(s): 3791


[align=left]Problem Description[/align]
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array
of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

 

[align=left]Input[/align]
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case
letters. The last input set is followed by a line containing a single 0, indicating end of input.

 

[align=left]Output[/align]
Each input set should generate one line of output, giving the original plaintext message, with no spaces.

 

[align=left]Sample Input[/align]

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

 

[align=left]Sample Output[/align]

theresnoplacelikehomeonasnowynightx
thisistheeasyoneabC语言程序代码/*
题目大意:先给定一个任意整数n,然后输入一串字符,按“倒S”形排列
成一个n列任意行的二维队列。然后将二维队列字符逐一输出,但输出
是按照 先列后行的顺序输出。*/
/*
解题思路::
   先定义一个一维字符数组,输入字符串,然后定义一个二维字符数组
   存放一维字符数组的字符,然后将二维字符数组行列互换,逐一
   输出字符。
难点::
   将一维字符数组中的字符存放到二维数组中。
心德::
   要细心,找出规律。
*/
#include<stdio.h>
#include<string.h>
int main(){
 int n,i,j,k,l,t;
 char a[201][201],b[201];
 while(scanf("%d",&n),n)
 {
  getchar();
  gets(b);
  t=0;
  l=strlen(b);
  k=(double)l/n;
  if(k>l/n)
      l=(int)k+1;
  else
      l=(int)k;
  for(i=1;i<=l;i++)
  {
   if(i%2==0)
       for(j=n;j>0;j--)
           a[i][j]=b[t++];
   else
       for(j=1;j<=n;j++)
           a[i][j]=b[t++];
  }
  for(j=1;j<=n;j++)
      for(i=1;i<=l;i++)
          printf("%c",a[i][j]);
          printf("\n");
 }
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: