您的位置:首页 > 其它

hdu 1061 Rightmost Digit

2015-07-21 21:18 519 查看
Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4


Sample Output

7
6


思路:简单的二分,唯一要注意的是使用long long 防止数据溢出的

#include <iostream>
#include <stdio.h>
using namespace std;
typedef long long ll;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int x,n;
scanf("%d",&x);
n=x;
int ret=1;
while(n)
{
if(n&1)
ret=(ll)ret*x%10;
n>>=1;
x=(ll)x*x%10;
}
printf("%d\n",ret);
}
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: