您的位置:首页 > 其它

HDU 1143

2015-07-21 19:35 323 查看


Tri Tiling

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2764 Accepted Submission(s): 1559



Problem Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.



Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1


Sample Output

3
153
2131


#include<stdio.h>

using namespace std;

int n;
long long dp[32];

int main()
{
dp[0] = 1;
dp[2] = 3;
dp[4] = 11;
for(int i = 6; i < 32; i+=2)
dp[i] = 3*dp[i-2] + dp[i-2] - dp[i-4];
while(~scanf("%d",&n))
{
if(-1 == n)
break;
printf("%lld\n",dp
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: