您的位置:首页 > 其它

poj--1905 Expanding Rods(二分)

2015-07-21 19:05 267 查看
Description


When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

题意大致是给定一根木条的长度,温度,以及膨胀系数,求出该木条中点上升的高度。


又从图中得到三条关系式;(1)       角度→弧度公式  θr = 1/2*s(2)       三角函数公式  sinθ= 1/2*L/r(3)       勾股定理  r^2 – ( r – h)^2 = (1/2*L)^2由这三个公式可以推出弧长s,与h,l,r之间的关系,然后再二分h的长度,与S进行比较最终确定H的长度,需要注意这题会卡精度,还有浮点数的输出要注意一下,如果在G++下必须用%.3f,而在C++下%.3lf与%.3f都可以,这是最坑的地方,WA了多次才找到原因。

#include <iostream>
#include <cstdio>
#include <string.h>
#include <math.h>
#include <iomanip>
#define EPS 1e-5
using namespace std;
int main()
{
double len,C,exp;
while(~scanf("%lf%lf%lf",&len,&C,&exp))
{
double lci,R,s;
if(len<0&&C<0&&exp<0) break;
lci=(1.0+C*exp)*len;
double l=0,r=len*0.5,mid=0;
while(r-l>EPS)
{
mid=(r+l)/2;
R=(len*len+4*mid*mid)/(8*mid);
s=asin(len/(2*R))*2*R;
if(s<lci) l=mid;
else r=mid;
}
//cout<<fixed<<setprecision(3)<<mid<<endl;用这个输出也可以
printf("%.3lf\n",mid);//这是在C++下,如果是G++改为%.3f,才可以过
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: