您的位置:首页 > 其它

POJ Treasure Exploration 2594【Warshall求传递闭包+最小路径覆盖】

2015-07-21 17:04 274 查看
Treasure Exploration

Time Limit: 6000MSMemory Limit: 65536K
Total Submissions: 7203Accepted: 2940
Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.

Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.

To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one
end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points,
which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.

For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.

As an ICPCer, who has excellent programming skill, can your help EUC?
Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following
M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output

For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0

Sample Output
1
1
2

Source

POJ Monthly--2005.08.28,Li Haoyuan

有向图最小路径覆盖 因为是可以重复一个点的使用 所以要先求该图的传递闭包 (推荐:Warshall传递闭包算法)。然后再求最小路径覆盖

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int p[510];
bool used[510];
bool map[510][510];
int n,m;
void Rt()
{
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				map[i][j]=(map[i][j]||(map[i][k]&map[k][j]));
			}
		}
	}
}
bool find(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(!used[i]&&map[x][i])
		{
			used[i]=true;
			if(p[i]==-1||find(p[i]))
			{
				p[i]=x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	while(scanf("%d%d",&n,&m),n!=0||m!=0)
	{
		memset(p,-1,sizeof(p));
		memset(map,0,sizeof(map));
		int a,b;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			map[a][b]=1;
		}
		int num=0;
		Rt();
		for(int i=1;i<=n;i++)
		{
			memset(used,0,sizeof(used));
			if(find(i))
			num++;
		}
		printf("%d\n",n-num);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: