您的位置:首页 > 其它

uva 674 Coin Change 经典dp入门

2015-07-21 10:43 393 查看
Coin Change

Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu

Submit Status Practice UVA 674

Appoint description:

Description

Download as PDF

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11

26

Sample Output

4

13

递推式

/*
Author:ZCC;
Solve:dp[i][j]:表示如果只使用前j种硬币,那么可以组成i的可能结果数
*/
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<fstream>
#define pb(s) push_back(s)
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
using namespace std;
typedef vector<int> VI;
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define bug printf("===\n");
#define PL(x) push_back(x)
void max(int&a,int b){if(a<b)a=b;}
const int maxn=7900;
const int inf=999999;
typedef long long LL;

int coin[]={1,5,10,25,50};
int n,ans;
int dp[maxn][5];

int main(){
for(int i=0;i<maxn;i++)dp[i][0]=1;//如果只使用1元的硬币 那么很明显只有一种可能
for(int j=0;j<5;j++){
for(int i=0;i<maxn;i++){
for(int k=0;i-k*coin[j]>=0;k++){
dp[i][j]+=dp[i-k*coin[j]][j-1];
}
}
}
while(~scanf("%d",&n)){
printf("%d\n",dp
[4]);
}
return 0;
}


记忆化搜索

#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<fstream>
#define pb(s) push_back(s)
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
using namespace std;
typedef vector<int> VI;
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define bug printf("===\n");
#define PL(x) push_back(x)
void max(int&a,int b){if(a<b)a=b;}
const int maxn=10005;
const int inf=999999;
typedef long long LL;

int coin[]={1,5,10,25,50};
int n,ans;
int dp[maxn][5];
int dfs(int i,int j){

if(j==0)return dp[i][j]=1;
if(dp[i][j]!=-1)return dp[i][j];
dp[i][j]=0;
for(int k=0;i-k*coin[j]>=0;k++){
dp[i][j]+=dfs(i-k*coin[j],j-1);
}
return dp[i][j];
}

int main(){
cl(dp,-1);
while(~scanf("%d",&n)){
printf("%d\n",dfs(n,4));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: