您的位置:首页 > 其它

HDU 1003 Max Sum(最长连续子串和)

2015-07-21 10:02 375 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 175786    Accepted Submission(s): 40946


[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

ac代码:
#include<stdio.h>
#include<string.h>
int num[100005];
int main()
{
int n,m;
int q=1,i,j;
scanf("%d",&n);
while(n--)
{
int sum,b,e;//开始.结束和子串和
int max;
int k=1;
int bz=0;//全部都是负数的时候标记为0
scanf("%d",&m);
for(i=1;i<=m;i++)
scanf("%d",&num[i]);
sum=b=e=max=0;
for(j=1;j<=m;j++)
{
if(num[j]>0)//存在大于0的数,修改标记
bz=1;
sum+=num[j];
if(sum<0)
{
sum=0;
k=j+1;
}
if(sum>max)
{
max=sum;//修改变量
b=k;
e=j;
}
}
if(bz==0)//全部为负数,所以怎么加都是变小,只有求最大的那一个负数
{
max=num[1];
b=e=1;
for(j=2;j<=m;j++)
if(num[j]>max)
{
max=num[j];//找到修改起点和终点
b=j;
e=j;
}
}
printf("Case %d:\n",q++);
printf("%d %d %d\n",max,b,e);
if(n>=1)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: