您的位置:首页 > 产品设计 > UI/UE

杭电1005Number Sequence

2015-07-20 22:18 363 查看

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 126495 Accepted Submission(s): 30758


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).



Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.



Output
For each test case, print the value of f(n) on a single line.



Sample Input
1 1 3
1 2 10
0 0 0




Sample Output
2
5


#include<stdio.h>
int main()
{
	int n,x,y,z,i;
	int a[100];
	a[1]=1;
	a[2]=1;
	while(~scanf("%d %d %d",&x,&y,&z))
	{
		if(x==0&&y==0&&z==0)
		return 0;
		for(i=3;i<=49;i++) 
		{
			a[i]=(x*a[i-1]+y*a[i-2])%7;
		}
		printf("%d\n",a[z%49]);
	}
	return 0;
}
注意:int的数值范围有限,当数值z大时会有数值溢出,又因为对7取余,所以以49为周期取z%49的数值代替z;

for循环要i<=49结束

根据周期,可以快速获得结果,且周期必定小于49.

周期的原因:如果<f(x),f(x+1)>的值与<f(x+T),f(x+1+T)>一致,那么以后的序列就完全一致了。

周期小于49的原因: 由于mod 7,所以<f(x),f(x+1)>的可能为49个,那么50个这样的<f(x),f(x+1)>必定有两个相同(鸽笼原理),所以最终可以确定周期小于49.

2、需要注意的是:并不是整个序列是有周期的,而是其中去掉头部一部分以后是有周期的!!!举个特殊的例子A=7,B=7,那么{f(x)}为{1,1,0,0,0,0,...},其在去掉头部的两个1后是有周期的,所以应该求出这个头部。类似的例子还有{A=2,B=7},{A=3,B=7}...
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: